|
|
Email Didn't Send: Attached Report Failed -- Sage Printer Driver Error
The email(s) from a MyAssistant Task didn't send because an attached report failed to run.
Reports used to create PDFs still use printer drivers to determine things like page margins, text size, character spacing and more. In this case, an attached report failed to run due to a Sage printer driver error.
Next Steps
In most cases, this error occurs because the default printer selected on the server is a network printer that the Windows User the MyAssistant sending process (Service: ISDAdminSenderService) can’t access. Two possible solutions exist:
Update MyAssistant's Sending Process
1. Log on to the machine where the MyAssistant Server software is installed (in most cases, this is your Sage Server)
2. Right-click on the Windows Start button and select “Run”
3. Type “services.msc” and click OK
4. Right click on the service “ISDAdminSenderService” in the window that opens
5. Select “Properties”
6. Click on the “Log On” tab of the window that opens
7. Click the circle next to “This account:”, then click Browse
8. Click “Locations” in the window that opens
9. Select “Entire Domain” and click OK
10. Type the administrator Windows username in the box labeled “Enter the object name to select”
11. Click “Check Names”
12. Click “OK” to close the window
13. Enter the Windows user’s password in the two designated fields and click “Apply”
14. Click “OK” to close the window(s) that appear and the Properties window
15. Right-click on the “ISDAdminSenderService” and select “Restart”
16. Re-Run the MyAssistant Task
Change the Printer Driver
1. Open MyAssistant, click File, then select “Options”
2. Click “Server Settings” on the left side of the window that opens
3. Write down the Sage User listed & locate its password
4. Click OK to close the window
5. Log on to the machine where the MyAssistant Server software is installed (in most cases, this is your Sage Server)
6. Right-click on the Windows Start button and select “Run”
7. Type “services.msc” and click OK
8. Scroll down to “ISDAdminSenderService” and check the “Log On As” column
a. If the service is set to “Log On As” an account called “Local System”, update the service to run as the Windows user used to log on to the computer (use the steps from the previous solution)
b. If it's set to “Log on as” a Windows user other than “Local System”, log off the server and log back on as the Windows user specified (if not already)
9. Minimize the Services window
10. Click the Windows Start button and type “Printers”
11. Select “Printers & Scanners” from the list
12. Select a local printer driver (e.g. TS PDF Generator, Microsoft Print to PDF, or Microsoft XPS Document Writer)
13. Click “Set as default”
14. Log in to a Sage application (e.g. Job Cost) on the server using the Sage user & password from Step 3
15. Click “File” and select “Print Settings”
16. Choose the same printer in the dropdown that was set as the default in Windows
17. Close Sage
18. Reopen the Services window
19. Right-click on “ISDAdminSenderService” and select “Restart”
20. Log off the server
21. Open the MyAssistant Designer and run the Task again
|
|